Greekbill Platform Alert Notification
Incident Report for Greekbill
Resolved
This incident has been resolved.
Posted Sep 04, 2024 - 14:43 PDT
Update
We are continuing to monitor for any further issues.
Posted Sep 04, 2024 - 14:42 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 04, 2024 - 14:27 PDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 04, 2024 - 12:30 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 04, 2024 - 10:14 PDT
Investigating
When accessing greekbill, you and your members may experience significant processing and navigation delays. Our team has identified the cause and is actively working toward a resolution. Rest assured, our teams view this as urgent and are actively working to solve this for you.

We appreciate your patience and partnership. For immediate support, please contact us at support@greekbill.com.
Posted Sep 04, 2024 - 07:56 PDT
This incident affected: Greekbill Application.